Problems loading forms in UK for BT clients
Incident Report for Typeform
Resolved
Good news for you chaps out in the UK: the issue between BT and Amazon has been resolved as reported by Amazon: http://status.aws.amazon.com/
Posted Aug 24, 2015 - 19:51 CEST
Monitoring
British Telecom is having DNS problems connecting to Amazon Cloud Front services which Typeform uses. Affected users will not be able to load our website our your typeforms. Amazon is aware of the issue and we expect it to be resolved soon: http://status.aws.amazon.com/
As a workaround, end users can change their resolvers to use a public DNS resolver. If you want help with this please contact support@typeform.com
Posted Aug 24, 2015 - 17:57 CEST